Adobe Flash Player NPAPI for Linux が復活ぽい

てことでちょっと試してみました.

update-flashplugin-nonfree では見えないようです.ベータだししょうがないですね.

$ sudo /usr/sbin/update-flashplugin-nonfree --status
Flash Player version installed on this system  : 11.2.202.632
Flash Player version available on upstream site: 11.2.202.632
flash-mozilla.so - auto mode
  link best version is /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so
  link currently points to /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so
  link flash-mozilla.so is /usr/lib/mozilla/plugins/flash-mozilla.so
/usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so - priority 70
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50

ということで手動で.何時もの感じで動きました.

$ wget https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/linux64/libflashplayer.so
$ mv libflashplayer.so ~/.mozilla/plugins/
$ sha256sum ~/.mozilla/plugins/libflashplayer.so 
413a82524b218ce49869bd9756fe4e85de0feb43e50737f05e5632599394f488  /home/mk/.mozilla/plugins/libflashplayer.so
$ firefox-esr about:plugins

とりあえず艦これが動くのは確認.

20160905_22:09:07-5170

20160905_22:09:23-7621

消すときはこんな感じで

$ rm ~/.mozilla/plugins/libflashplayer.so

ブラウザ側ではサポート打ち切っていく方針だと思うのですが Adobe はどういう心変わりなんでしょうね? Google ChromeのPPAPIはどうなるかな?

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です